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Purpose of this lab

After completing this lab, you should be able to apply different types of data transformations using
PowerBI desktop so that the data inconsistencies can be removed. You also would be able to learn how to
model your data, imported from various sources. In this section you’d learn how to create relationships
between different tables either using the auto-detect option or by creating them manually.

Data transformation
Change datatype

1) Launch PowerBI desktop.

2) Open the previously saved “Healthcare Dashboard” report.

3) From the “Home” menu, click on the “Edit Queries” icon.

4) In the “Query Editor” window, right click on the “Visit Date” column from “Visits” table and
from the “Change Type” submenu, choose “Date”. Repeat the same step for “Discharge Date”.

5) Navigate to the “Patient Master” table, right click on the “DOB” column header and from the
“Change Type” submenu, choose “Date”. Ignore this step if the datatype is already set to

“ ”
Date”.
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Capitalize column

1) Navigate to the “Visits” table, right click on the “BMI Category” column, navigate to “Transform”
and select “Capitalize each word” option.

2) Navigate to the “Doctor Master” table and repeat the previous step for “Doctor Names” column.

M0l <
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Remove columns

Note: There are certain columns that contains incorrect data or a piece of information we don’t
require to satisfy the reporting requirements. So, let’s remove such columns from the dataset.

1) Navigate to the “Visits” table, right click on the “Visit Day” column and click on “Remove”.
Repeat the same step for “Visit Month” column. These columns contain incorrect information.

2) Similarly navigate to the “Billing” table and remove the “Visit Date” and “Visit Year” columns
as they’re not required forsatisfying any of the reporting requirements.

Rename columns

1) Navigate to the “Doctor Master” table, right click on the “Doctor Names” column and click on
“Rename”. Rename the column as “Primary Physician” and hit Enter.
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Split columns

1) Inthe “Visits” table right click on the “Patient Gender|Visit Type” column and from the “Split

2)

3)
4)
5)

Column” submenu, select “By Delimiter”.
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The system would automatically detect the detect the delimiter.

select “Custom” from the listof delimiters.

Type | in the delimiter textbox.

Choose “Each occurrence of the delimiter” option.

Click on “Ok”.
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Split Column by Delimiter

Specify the delimiter used to split the text column.

Select or enter delimiter

--Custom--
|

Split at
Left-most delimiter

Right-most delimiter

® Each occurrence of the delimiter

4 Advanced options
Split into
® Columns
Rows
Number of columns to split into

2

Quote Character

Split using special characters

—

OK

Cancel

6) After the columnis split, right click on the “Patient Gender|Visit Type.1” column header and
select “Rename”. Rename the column as “Gender”.
7) Right click on the “Patient Gender | Visit Type.2” column header and select “Rename”. Rename
the column as “Visit Type”.
8) From the “Home” menu, click on “Close & Apply” button.
9) The changes would be applied on the model and the same can be viewed in the “Data View”.
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Note: All the applied transformations can be viewed from the “Applied Steps” window. From this
window you canselectively undo any of the applied transformations by clicking on the cross sign.

Rows ™ Rows ¥ Column~ By % Replace Values |£4| Combine Files
Reduce Rows  Sort Transform Combine
{{"Discharge Date", type date}}) v Query Settings X
te ~|1.2 Total Stay ~| /1.2 Discharge Disposition [~ 4 PROPERTIES
2/18/2015 3 7 Name
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1/23/2015 8 2
5/17/2012 0 1 All Properties
6/29/2015 9 8
4 APPLIED STEPS
3/15/2012 8 7
8/19/2015 10 7 Source
6/9/2016 0 1 Navigation
1/27/2015 0 1 Changed Type
5/2/2017 10 P Removed Columns
Split Column by Delimiter
3/17/2014 8 2
Changed Typel
10/25/2012 0 1
Renamed Columns
s > > Capitalized Each Word
9/21/2013 0 1 @hanged T
7/28/2013 0 1
9/2/2016 3 Z
10/6/2012 5 3

Similarly, when you apply a transformation using the “Edit Queries” screen, the system generates an
MQuery code that can be copied and reused on another table. This code can be found in the “Advanced
Editor” window, under the “Home” menu.
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No syntax errors have been detected

Assign data category

1)
2)
3)
4)
5)

6)

Navigate to the “Data View”.

Expand the “City Master” table from the “Fields” panel on the right.

From the “City Master” table select the “City Name” field.

Navigate to the “Modeling” tab at the top and change the “Data Category” to “City”.

The “City Name” should have a small globe like icon next to its name appearing under the “Fields”
panel on the right. This shows that this column name is now treated as a geographic dimension
(something that can be used with a Map visualization).

Save all the changes to file.

Merge queries

1) Launch PowerBI desktop.

2) Open the previously saved report where you’ve been doing some addhoc practice.

3) From the “Home” menu, click on “Get Data” button.

4) Onthe “Welcome screen”, select “File” from the left-side list and “Excel” from the right-side list.

5) Click on “Connect”.

6) Locate the “Merge Queries” excel file and click on “Open”.

7) From the “Navigator” window, choose “Table — Amount” and “Table — Price” tables and click on
“Edit”.

8) Select the “Table — Price” table.

9) From the “Home” menu, expand the “Merge Queries” option and select “Merge Queries as
New”.
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Hame Trantform Add Codumn View

o=z {} Y P froperties r ] -yl w4 - == Data Type: Whole Numbes = T Merge Quenes -
: ol | . il
L &= -

- . L) Aoanced Eator == X sauiess 7| = [3 Use First Row As Headers = | T2 Merge Quenes
New  Recent  Enter | Doty source Manage Refresh Chodse  Remove Keep Remove Soht Growo e - -
Seurce = Sowces = Data settings  Pasametens=  Preview = [ Manage * Cotumns = Codumns = Rows = Rows = Column= By oz Replace Valuey |
New Query Dats Soueces  Parameters Query Marage Codumns Reduce Rows  Sant Transform

Merge this query v
query in this Pée

10) In the “Merge” screen, ensure “Table — Price” is selected as the first table and “Table —
Amount” is selected as the second table.

11) Highlight the “Visit ID” column in both the selected tables. 12) Select the “Join Kind” as “Left
Outer” and click on “Ok”.

Merge
Select tables and matching columns to create a merged table.

Table - Price - )

Visit ID Prjce
7353
385
286

3322

(O S T =Y

Table - Amount ¥ [‘1

Amount

8280
778
772

3810
609

[ ST ST

Join Kind

Left Outer (all from first, matching from second) ¥

1 irst 1 \
v/ The selection has matched 15 out of the first 15 rows. oK Cancel

13) On the “Query Editor” window, select the new “Mergel” table that got created.

14) On the “NewColumn” column header, you’d find an icon that looks like two arrows pointing in
opposite direction. Click onthat icon and make sure that,

“Expand” radio button is selected.

“Visit ID” checkbox is unchecked.

“Amount” checkbox is checked.

“Use original column name as prefix” checkbox is checked.

o 0 T o
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Quenes 2] < fx = Table.Nestealoin(#"Table - Price”, {"Visit ID"}, #"Table - Asount", {"Visit ID*}, "Table - Amount™,

[ Table - Amount 3. 123 Vsitid ~| 123 Price =[] Table - Amount (Y

[ Table - Price 2l
T Mergel 2  Expand Aggregate

ct All Columns)

¥ Use oniginal column name as prefix

oK Cance!
2 421
13 3211
14 7706
15 1694

15) Click on “Ok”.
16) From the “Home” menu, click on “Close & Apply” button.
17) The new “Mergel” table should contain all the columns of “Table — Price” and “Table — Amount”

tables.
[1al X Fields >

Visitip [~] Price [~] Amount [~
1 7353 8280 L search
2 385 778

ﬁg 3 286 772 ~ B Mergel
4 3322 3810 > Amount
5 444 509 )
N = 3 Price
671 1155
7 2136 2753 Visit 1D
8 481 885 v E§ Teble - Amount
2 2 253 ~ B Teble - Price
10 7837 3430
1 5620 §070 iR Erice
12 4417 2873 Visit ID
13 3211 7559
14 7706 5163
15 1694 7168
Append queries

1) Launch PowerBI desktop.

2) Open the previously saved report where you’ve been doing some addhoc practice.

3) From the “Home” menu, click on “Get Data” button.

4) Onthe “Welcome screen”, select “File” from the left-side list and “Excel” from the right-side list.

5) Click on “Connect”.

6) Locate the “Append Queries” excel file and click on “Open”.

7) From the “Navigator” window, choose “Tablel”, “Table2 and “Table3” tables and click on “Edit”.
8) From the “Home” menu, expand the “Append Queries” option and select “Append Queries as
New”.
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Home | Transform  AddColumn  View
D D D [h = Eﬁ [i2 Properties L Yy, mx | 8| ¥ 1 DataType: Whole Number ~ I Merge Queries ~
) } - s ) HH |2 —
. LS = %7 [} Advanced Editor X HH HH zl [11] [ Use First Row As Headers ~ [;.'?';Appma Queries. ]
New Recent Enter | Datasource = Manage | Refresh Choose Remove | Keep Remove Spiit  Group , =
Preview ~ [ Manage ~ Columns ~ Columns ~ | Rows ~ Rows~ Column~ By % ReplaceValues ’E&, Append Queries

Source ~ Sources ~ Data settings Parameters ~

i
Data Sources | Parameters Query Manage Columns Reduce Rows | Sort Transform |Z Append Queriesas New |

New Query

9) Onthe “Append” screen choose, “Three or more tables” option.
10) From the “Available Table(s)” list select, “Tablel”, “Table2” and “Table3”. 11) Click on “Ok”.

Append
Two tables @ Three or more tables
Available table(s) Tables to append
Tablel Tablel
Table2 Table2
Table3 Table3

Add >>

oK Cancel

11) On the “Query Editor” a new table should be created called “Append1”. This table should
contain all the records from all the tables.

12) Click on “Close & Apply” to apply the changes.

Manage relationships
Auto-detect relations

PowerBl auto detects relationships between tables when you import them from a particular data
source. The system essentially looks for columns with same name and datatype and automatically
creates the relationships. While creating a relationship it alsosets an appropriate cardinality and cross
filter direction. Open the previously saved “Healthcare Dashboard” report and navigateto the “Model”
view to see few relations being created automatically by the system.
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You can also turn off the auto detect option if you want, by following the below mentioned steps.

1) Inthe same “Healthcare Dashboard” report, navigate to the “File” menu and from “Options and
Settings”, choose“Options”.

1] New

|2 T Options

Open

H Save
B‘ Save As

'y
Data source settings
L4 Y

. GetData ’
F’" Import »

.|$ Publish »

pdfl  Export to PDF
]

. {} Options and settings »

0 Help >

h Get started

What's new

& Sign out

Power BI

Module 3




2) Navigate to the “Data Load” section that appears under “Current File”.
3) Uncheck the checkbox that reads, “Autodetect new relationships after data load”. 4) Click on Ok
to save the changes.

You can also enforce the autodetect relationships manually, by following the below mentioned steps.

1)
2)
3)
4)

Open the “Healthcare Dashboard” report and navigate to the “Model” view.

Options

GLOBAL

Data Load

Power Query Editor
DirectQuery

R scripting
Python scripting
Security

Privacy

Regional Settings
Updates

Usage Data
Diagnostics
Preview features
Auto recovery

Report settings

CURRENT FILE

Data Load
Regional Settings
Privacy

Auto recovery
DirectQuery

Query reduction

Type Detection

¥ Automatically detect column types and headers for unstructured sources
Relationships
¥ Import relationships from data sources on first load (D

Update or delete relationships when refreshing data @O

Autodetect new relationships after data is loaded © |

Learn more

Time intelligence
¥ Auto date/time (D
Background Data

¥ Allow data preview to download in the background

Parallel loading of tables

¥ Enable parallel loading of tables

Q&A

¥ Turn on Q&A to ask natural language questions about your data (D

Under the “Home” menu, click on “Manage Relationships”.

On the “Manage Relationships” screen, click on “Autodetect” and then click on “close”.
This should force the system to automatically detect and create more possible relationships in

the model.
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Creating Custom Relatio

In the “Healthcare Dashboard” report, to manually create your own relationships, follow the below
mentioned steps. To have better control over your data model, you might want to delete the

Manage relationships

From: Table (Column)

Billing (Visit ID)

Patient Medications (Medicine ID)
Patient Medications (Visit ID)
Patient Medications (Visit ID)
Patient Procedures (Procedure ID)
Patient Procedures (Visit ID)

Patient Tests (Test ID)

nships

Insert Custom visuals Themes

To: Table (Column)

Visits (Visit ID)

Medicine Master (Medicine ID)
Patient Procedures {Visit ID)
Patient Tests (Visit ID)

Procedures Master (Procedure ID)
Patient Tests {Visit ID)

Test Master (Test ID)

autodetected relationships first. To delete the existing relationships,

o

Manage
Relationships

Relationships

1) Navigate to the “Model” view and click on “Manage Relationships”.
2) Select all the relations by holding the shift key (so that they all get highlighted).
3) Click on the “Delete” button.
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Manage relationships

Active From: Tabie (Column) To: Table (Column)

v Billing (Visit ID) Visits (Visit 1D)

v Patient Medications (Medicine ID) Medicine Master (Medicine ID)

v Patient Medications (Visit ID) Patient Procedures {Visit ID)

v Patient Medications (Visit ID) Patient Tests (Visit 1D)

v Patient Procedures (Procedure 1D) Procedures Master (Procedure ID)
Patient Procedures (Visit ID) Patient Tests (Visit ID)

v Patient Tests (Test ID) Test Master (Test ID)

New... Autodetect... Edit. Delete

To create a new relationship,

1)
2)
3)

4)
5)
6)

7)
8)

Navigate to the “Model” view and click on the “Manage Relationships” button.

Click on the “New” button.

To create a relationship between the “Visits” and “Billing” table, select the “Visits” table from the
top section.

Select the “Billing” table from the bottom section.

Highlight the “Visit ID” column in both the sections by clicking on the column header.

Make sure that the system sets the “Cardinality” as “One to Many” and the “Cross filter
direction” as “Single”.

“Make this relationship active” checkbox should be checked.

Click on Ok to save the relationship.
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Create relationship

Select tables and columns that are related.
Visits .
Visit ID Visit Date Visit Day Visit Month Center ID Patient ID Patient Age Age Group
163 | 8/3/2017 12:00:00 AM Fri Jan 25 3417 78 61-90
322 §1/20/2012 12:00:00 AM Sun Jan 9 13538 72 61-90
714 |5/12/2012 12:00:00 AM Sun Jan 24 2855 81 61-%0
< >
Billing > I
Visit ID Visit Date Visit Year Charge Group Charge/Doctor 1D Units Sold
50 30/21/2013 12:00:00 AM 2013 Medicine 87 9
100 }10/5/2013 12:00.00 AM 2013 Medicing 365 9
104 |2/26/2013 12:00:00 AM 2013 Medicine 354 9
Cardinality Cross filter direction
One to many (1:°) *  Single v
¥ Make this relationship active
oK Cancel

10) Click on “Close” on the “Manage Relationships” screen.

11) When you get back to the “Relationships View”, you see the newly created relationship being
displayed using connector lines.

117 Billing
% Ohargs Group
[T8 Charge/Doctor ID

Units Scld

71 Ag= Group
T BM:

{8 BMI Categary
03 Center ID
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In the same way create the below mentioned relationships to configure the data model as per the
reporting requirements.

Column Name Table To Column Cardinality Filter Activ
Name Direction e
Visits Visit ID Billing Visit ID One to Single Yes
many
Visits Center ID City Master City ID Many to Single Yes
one
Visits Patient ID Patient Master PatientID Many to Single Yes
one
Visits Doctor ID Doctor Master ID Many to Single Yes
one
Visits Primary Diagnosis Master Diagnosis = Many to Single Yes
Diagnosis ID ID one
Visits Discharge Discharge Disposition Discharge = Many to Single Yes
Disposition Master ID one
Visits Visit ID Patient Medication  Visit ID One to Single Yes
many
Visits Visit ID Patient Procedures | Visit ID One to one Single Yes
Visits Visit ID Patient Tests Visit ID Oneto one Single Yes
Billing Charge/Doctor = Doctor Master ID Many to Single Yes
ID one
Billing Charge/Doctor Medicine Master Medicine  Many to Single Yes
ID ID one
Billing Charge/Doctor = Procedure Master Procedure | Many to Single Yes
ID ID one
Billing Charge/Doctor = Test Master Test ID Many to Single Yes
ID one

Once you create all the above-mentioned relationships, the relationship view should look like the
screenshot shown below. Please note while creating the relationships, the system might make some of
the relations inactive. This happens due to a circular reference.

While creating a relationship between two tables, if another indirect relationship is detected by the
system (between the same set of tables), the current relation is then set as inactive. This is because
you can have only one active relationship between two tables. Leave these settings to default as the
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system controls the active / inactive checkbox.

= Medicine Master
'3 ftio... .- (T8 Brand Name
D‘ﬂ' -‘ 9‘» Bepe I8 Generic Name
a3 Dg;.npnan 2 < T2 Medicine ID
[71 Discharge ID 3 Unit Price

3 doctor names
T Fes

D

=3 Speciality 7 Billing

1 Charge Group

A Cnarge/Coctor D

{28 Diagni
73 1ICD Code

Procedures Master
1 Price
EX Procedurs ID

3 Procedurs Name
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% Gty ID

Gty Name

£1 Age Group
=1 BM
T BMI Category

harge Dispesition
=3 Doctor ID
73 Height {m)
7 Patiznt Age
™7 Patient Gender{Visit Type
23 PatientID
=3 Primary Diagnosiz 1D

sit Month

73 Weight (ka)

" Patient Master
£2 DOB

£1 Gender

1 Patient ID

[T Patiznt Name

¥ Medicine ID

Patient Procedures
I3 Procedure ID
3 Visic ID




