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Purpose of this Lab 

After completing this lab, you should be able to, 
 

• Create interactivity between various visuals on your report. 

• Using Basic, Advanced and TopN filtering options. 

• Apply sorting on visuals. 

• Create a custom group and use it in a visual. 

• Create a custom hierarchy and use it for drilling on a visual. 

 

 

Interactivity and Analytics 

Creating Slicers 

Creating a Month Slicer 

1. Open the saved dashboard you’ve created in the previous lab and navigate to the “Hospital 
Performance” page. 

2. From the visualization gallery click on the “Slicer” visual and navigate to the “Fields” pane. 

3. Drag the “Month” dimension and drop it on the “Fields” box. 

4. Navigate to the “Format” panel and expand the “General” section. 

5. Make sure the “Orientation” to “Vertical”. 

 

6. Now expand the “Selection controls” section and 

a. Turn off the “Single select” option. 

b. Turn on the “Multi-select with CTRL” option. 

c. Turn off the “Show select all option”. 
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7. Select the slicer you just created and navigate to the “Format” menu at the top. 

8. Enable the “Edit Interactions” button. 

9. As soon as you enable this button, you’ll be able to see a couple of icons  (named filter and 

none) appearing on top of every visual. 

10. While the month slicer is selected, make sure that the “Filter” icon is enabled only on the scatter 

chart. For all the other visuals in the page, the “None” option should be selected. 

11. Now select different months from the month slicer and the scatter chart should show the data as 

per your selection. Please note, as you change your selection, none of the other visuals on the 
page should get targeted. 
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12. Navigate to the “Format” pane and make sure the following options are turned off. 

a. Header 

b. Title 

c. Background 

d. Lock aspect 

13. Turn on and expand the “Border” section. 

a. Set the “Color” as # 666666. 

 

Creating a Year Slicer 

1. From the visualization gallery click on the “Slicer” visual again and navigate to the “Fields” pane. 

2. Drag the “Year” dimension and drop it on the “Fields” box. 

3. Navigate to the “Format” tab and expand the “General” section. 

a. Make sure that the “Orientation” is set to Horizontal. 

b. Turn off the “Responsive” slider. 

 

 

 

4. Turn on and expand the “Border” section. 

a. Set the “Color” as # 666666. 

5. Select the slicer you just created and navigate to the “Format” menu at the top. 

6. Enable the “Edit Interactions” button. 

7. While the year slicer is selected, make sure that the “Filter” icon is enabled for all the other visuals 
on the page except, 

b. The “Hospital Performance in Handling Disease” scatter chart. 
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c. Also make sure that the month slicer is also targeted by the year slicer. 

 

 

 

8. Now selecting a year from the year slicer should, 

a. Filter the data on every visual in the same page – apart from the scatter chart. 

b. Filter the months shown on the month slicer. 

9. Selecting a month from the month slicer should filter the data on the scatter chart. 
 

Synching a Slicer Across Pages   

If you wish to make the same slicer appear on multiple pages, PowerBI provides you an option to 

synchronize them across pages without creating the same slicer repeatedly. Moreover, this option also 

helps you in synchronizing the slicer selection across pages. This means if you have the “Year” slicer 

synchronized across pages and you select “2015” on the first page, the “Year” slicer selection on other 

pages will automatically change to “2015’. To synchronize the “Year” slicer across all pages, 
 

1. Select the “Year” slicer and navigate to the “View” menu from the top. 

2. Check the “Sync Slicer” option. This will open a new panel on the right. 

3. On the new “Sync Slicer” panel, you should see all the three pages listed. Next to each page name, 

you’ll see two checkboxes (for Sync and Visible). Check all the checkboxes. The setting should 
resemble the screenshot shown below. 
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4. Now the same “Year” slicer should appear on all three pages. Selecting a particular year on one 

page should automatically synchronize the selection on other pages as well. 
 

Using Visual as a Slicer 

In the previous section, we’ve seen how to use a slicer to filter data on different visuals appearing on a 

single page, or across multiple pages. It is also possible to use a visual to filter or highlight data on other 

visuals. Using the “Map” visual on the “Analysis by Discharge Disposition” page, we’d like to, 
 

• Filter data on the “Funnel Chart” and 

• Highlight data on the “Clustered column Chart”.  

Follow the steps mentioned below to achieve this. 

1. Navigate to the “Analysis by Discharge Disposition” page and select the “Map” visual. 

2. While the “Map” visual is selected, navigate to the “Format” menu appearing on top of the 

screen and click on “Edit Interactions”. 

3. We discussed earlier, this should start displaying the “Filter” and “None” icons on top of every 
visual on the page. 

4. Now configure the cross filtering in the following way. 

a. Select the “Filter” option on the “Funnel” chart, 

b. Select “None” for the “100% Stacked Bar” chart and the “Year” slicer, 

c. Select “Highlight” for the “Clustered Column” chart. 

5. Now click on the “Edit interactions” button again to disable these icons. 

6. Now click on any one of the bubbles on the “Map” visual. This should, 

a. Filter data on the “Funnel” chart, 

b. Highlight data on the “Clustered Colum” chart. 

c. Have no impact on the “Year” slicer and the “100% Stacked Bar” chart. 
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You may also hold the Ctrl key on your keyboard and make multiple selections on the “Map” visual. 
 

Using Advanced Filter Qualification 

Follow the below mentioned steps to apply a filter on the “Scatter chart”, using the “Advanced” filtering 

option. The purpose of applying this filter is to view only those disease names on the visual, that contains 

the word “eye” in it. 
 

1. Navigate to the “Hospital Performance” page and select the “Scatter chart” visual. 

2. Expand the filter panel on the right to view the “Visual level” filters. 

3. Expand the “Diagnosis name” pill and set the “Filter type” as “Advanced filtering”. 

4. Set the operator as “Contains” and enter “eye” in the box below. 

5. Click on “Apply filter” to see only the filtered values on the “Scatter chart”. 
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Using TopN Filter Qualification 

Follow the below mentioned steps to apply a filter on the “Scatter chart”, using the “TopN” filtering 

option. The purpose of applying this filter is to view the top 10 disease names by “Death Count” 

measure. 
 

1. First, reset the filter to remove the condition you just applied in the previous step, clicking on the 
“Clear filter” icon. 



 
 

 

Power BI 

Module 7 

 

 

2. Now under the “Diagnosis name” pill, select “TopN” as the “Filter Type”. 

3. From the “Show Items” drop box, select “Top”. 

4. Enter the value 10 in the textbox next to it. 

5. Expand the “Visits” table, drag the “Death Count” measure and drop it onto the “By Value” box. 

6. Click on “Apply filter” to see the top10 diseases by “Death count” measure. 
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Sorting Visuals 

1. Navigate to the “Analysis by Charge Group” page. 

2. Hover on the “Revenue and Units sold by Charge Group” visual. 

3. On the top right corner of the visual, you’ll see a “More options” ellipsis icon. Click on that icon, 

navigate to the “Sort By” option and select “%GT Revenue”. The visual should get sorted 

according to “%GT Revenue”. 

4. Click on the “More Options” icon again and select the sort order as descending. 

 
 

5. In the same way, sort the following visuals in the descending order using the measures mentioned 
below. 

a. “Top 5 Physicians” by “Visit Count”. 

b. “Top 5 Medicines” by “Medicine Order Count”. 

c. “Top 5 Procedures” by “Procedure Order Count”. 

d. “Top 5 Tests” by “Test Order Count”. 

 

6. Navigate to the “Death Analysis” page and sort the visuals as per the instructions mentioned 
below. 

a. Sort the “Admission Count by Discharge Disposition” visual by “Admission Count”. Sort 
order should be descending. 

b. Sort the “Death% by Age Group” visual by “Age Group”. Set the sort order to ascending. 
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Creating Groups 

PowerBI gives you an option to group elements of a dimension. For example, you can group “Nov”, “Dec”, 

“Jan” and “Feb” elements of the “Month” dimension and name it as “Winter season”. You can further use 
that group in a visual and the measure values would automatically aggregate according to the group 

you’ve created. The following steps would help you to group elements of the “Charge group” dimension. 
 

1. From the “Fields” section on the right, expand the “Billing” table. 

2. Click on the ellipsis icon next to the “Charge Group” dimension and select “New Group”. 
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3. On the “Groups” window, name the group as “Products and Services”. 

4. From the “Ungrouped values” list, select “Consultation”, “Test” and “Procedure” elements by 

holding the Ctrl key and click on the “Group” button. 

5. These three elements should now be grouped together and would appear on the right-side 
panel called “Groups and Members”. 

6. On the “Groups and Members” panel, double click on the group header and name is as “Services”. 

7. Similarly, select the “Medicine” element from the “Ungrouped values” panel and create a new 
group called “Products". 

8. At this stage the group should resemble the screenshot shown below. Click on ok to save it. 
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9. Now that the group is created, it should appear as a new object under the “Billing” table. 

 

10. Now select the “Clustered bar chart”, expand the “Billing” table and drag the “Products and 
services” group and drop it on the “Axis” drop box. 

11. After you drop the group on the “Axis” box, the visual should resemble the screenshot shown 
below. 
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Creating Custom Hierarchy 

In this section you’ll create a custom hierarchy using time the related dimensions “Year”, “Month” and 

“Date”. Further we’ll use the hierarchy in a “Clustered Column Chart” and drill down / up as per the drill 
path. Now this chart isn’t quite needed in the report. We are creating this simply for the purpose of 

practicing. Hence if you wish, you may as well delete the visual after performing this section. 
 

1. From the “Fields” section, expand the “Visits” table. 

2. Right click on the “Visit Date” column and select “New Hierarchy”. 

3. This would create a new hierarchy called “Visit Date Hierarchy”, which should have only the “Visit 
Date” column in it. 

 

4. Double click on the new created hierarchy, rename it to “My Time Hierarchy” and hit “Enter”. 

5. Now to add the “Year” level in the hierarchy, drag the “Year” column from the same table and drop 

it on “My Time Hierarchy”. The hierarchy should look like the screenshot below. 
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6. By default, the “Year” would appear as the second level in the hierarchy after “Date”. However, 

we want the “Year” to be the first level. To achieve this, drag the “Year” column from the hierarchy 

and drop it above “Visit Date”. Now the levels should look like this. 

 

7. In the same way, by dragging and dropping, add the “Month” column as well in the hierarchy. 
Please note that “Month” should appear below “Year” and above “Visit Date”. So the hierarchy 
should finally look like this. 

 
 

Now that the new hierarchy is created, let’s use it in a visual and see how we can drill on it. 
 

1. Select the “Clustered Column Chart” from the visual gallery. 

2. This would create an empty frame in the “Layout” area. 

3. Select the frame, drag the “My Time Hierarchy”, we just created and drop it on the “Axis” drop 
box. 

4. Now from the “Billing” table, drag the “Revenue” measure (created earlier) and drop it on the 

“Value” box. The visual should now look like this. 
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5. Observe that the visual by default is showing the “Year” level, as we’ve set that as the topmost 

level in the hierarchy. Moreover, there are a few new drilling icons appearing on the top left 
corner of the visual. 

6. Click on the second icon that reads, “Go to the next level in the hierarchy”. This should make 

the visual go down to the “Month” level. 

7. Similarly clicking on the same drilling icon again would make the visual go down to the “Visit Date” 
level. 

 
 

8. Similarly, to drill up again, you can click on the first icon that reads, “Drill up”. This would make the 

visual go up the dill path, created by the hierarchy. 

9. You can also do selective drilling by right clicking on one of the bars in the visual and selecting “Drill 
Down” option. 

 
10. Please note when you do selective drilling, the system would automatically create a local filter on 

the visual level, to show only the data you’ve requested for. So, in this case, if you right click on the 
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“2017” bar and select “Drill Down”, the system would create a local filter to show only the data for 

2017. 

 
 

Using Bookmarks for Page Navigation 

Follow the below mentioned steps to navigate between page using a bookmark. 
 

1. Open the PowerBI report you’ve been working on so far and navigate to the “Hospital 
Performance” page. 

2. From the “View” menu, check the “Bookmarks Pane”. 

 
 

3. In the “Bookmarks” pane, click on “Add”. This store the current view of the report in form of a 
bookmark. 

4. Right click on the newly created bookmark and rename it as “Page1 View”. 
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5. Similarly navigate to the “Analysis by Charge Group” page. 

6. While the second page is in view, click on “Add” again on the “Bookmarks” pane. 

7. Rename the new bookmark as “Page2 View”. 

 

 
 

8. Finally, navigate to the “Analysis by Discharge Disposition” page and create another bookmark for 
this page. 

9. Rename this one as “Page3 View”. Now you should have three bookmarks created in your 
“Bookmarks” pane (one for each page). Clicking on any of the bookmarks should show the 

associated view. 
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Now that you’ve created the required bookmarks, you need to associate them with action buttons, 

shapes or images. In this case we’ll create action buttons on each page and associate specific 

bookmarks with them. To create a button on the first page, 
 

1. Navigate to the “Hospital Performance” page. 

2. From the “Home” menu, expand “Buttons” and select “Right Arrow”. 

 
 

3. This should create a new shape in your page. Place it on the top-right corner of the page. 

 
 

4. Have the button selected. Now from the “Visualizations” pane, enable the “Action” option. 
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5. Now expand the “Action” section, set the “Type” as “Bookmark” and “Bookmark” as “Page2 View”. 

 
 

6. Now hold the Ctrl key on your keyboard and click on the button. You should get navigated to the 
“Analysis by Charge Group” page. Please note after the report gets published to the service 

account and it’s viewed using a web browser, you won’t  have to hold the Ctrl key. Just clicking on 

the button would be enough to make it work. 

7. Now in the “Analysis by Charge Group” page create two new action buttons (left arrow and right 
arrow). Once again place the buttons on the top-right corner of the page. 
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8. Have the left arrow button selected and from the “Visualization” pane, enable the “Action” option 

and associate the “Page1 View” bookmark with it. 

 

 

9. Similarly associate the “Page3 View” bookmark with the right arrow button. 

 
 

10. Finally navigate to the “Analysis by Discharge Disposition” page and create a left arrow action 
button. Place it on the top- right corner of the page. 

11. Have the left arrow button selected and from the “Visualization” pane, enable the “Action” option 

and associate the “Page2 View” bookmark with it. 

Now you should be able to navigate between pages using these action buttons. 
 

Using a Page as Tooltip 

In PowerBI, you can create a report page with some visuals in it and use that page as a tooltip on visuals 

of other pages. Let’s try to understand the use of such dynamic tooltip using the scenario mentioned 

below. 
 

Scenario: 

In the “Analysis by Discharge Disposition” page, we have a “Map” visual that shows the number of deaths 

by cities. Now we’d like to drill into further details and see, 
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a. The gender wise distribution of death for each city. 

b. The age group wise distribution of deaths for each city. 

Follow the below mentioned steps to create a dynamic tooltip of this kind. 
 

1. Open the PowerBI report you’ve been working on. 
2. Create a new page in the report and name the page as “Dynamic Tooltip”. 

 
3. Navigate to the “Dynamic tooltip page and set the following page properties. 

a. Right click on the page name and select “Hide Page”. This will make the page hidden when 

you publish it to the service account. We don’t want the users to navigate to this page 

manually like they can on other pages. The contents of this page should only be accessible 

as a tooltip on the “Map” visual. 

 
 

b. Go to the “View” menu, expand the “Page View” section and select “Actual Size”. 

 
 

c. Now go to the “Format” pane, expand the “Page Information” section and turn on the 

“Tooltip” option. 
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d. Expand the “Page Size” section and set the “Type” as “Tooltip”. 

 
4. Now create the following visuals in the page. 

a. Card Visual using the “Death Count” measure. Format the visual in the following way. i. Data 
Labels 

1. Text size – 16pt 

2. Font family – Calibri 
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ii. Category (turned on) 

1. Text size – 10pt 

2. Font family – Calibri 

 
 

b. Stacked Bar Chart using the “Gender” as “Legend” and “Death 

Count” as “Value”. Format the visual in the following way. 
i. Legend (turned on) 

1. Position – Left center 

2. Title – Off 

3. Font family – Calibri 

4. Text size – 8pt 

 
ii. X and Y axis should be turned off 

iii. Title should be turned off 

c. Clustered Column Chart using the “Age Group” as “Axis” and “Death 

Count” as “Value”. Format the visual in the following way. 

i. Y axis should be turned off  

ii. Data colors set to #7F312F  

iii. Data label should be turned on 



 
 

 

Power BI 

Module 7 

 

Finally, the tooltip page should resemble the screenshot shown below. 

 
 

5. Navigate to the “Analysis by Discharge Disposition” page. 

6. Select the “Map” visual and navigate the “Format” tab. 

a. Enable the “Tooltip” option and expand the section. 

b. Set the “Type” as “Report page”. 

c. Set the “Page” as “Dynamic Tooltip”. 

 
 

7. Now hover on the bubbles of the “Map” visual and you should be able to see the hidden page as a 

dynamic tooltip. Hovering on a bubble (city) would also apply a filter on the tooltip page. This way 

you’ll be able to see the data only for that city which you’ve hovered on. 
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